Monthly Archives: September 2016

How to manually enable Bitlocker on Hyper-V Gen 2 Virtual Machine

You can automatic enable Bitlocker on your Hyper-V Gen 2 virtual machine during OSD, please read Niall Brady’s post Here But if you already install a Hyper-V Gen 2 virtual machine, and you want to enable bitlocker, you can do it manually. Here are the steps: Open cmd as administrator Set XTS-AES256 Engryption

Allow enable bitlocker for… Read More »

Is this a good way to update ADK 1607 and custom boot image in SCCM?

NOTE: Read this article before you start do anything  https://blogs.technet.microsoft.com/enterprisemobility/2016/09/09/configuration-manager-and-the-windows-adk-for-windows-10-version-1607/ I don’t know if this is a good way to update ADK 1607 and custom the winpe.wim, that is how I did it. Since I have not been any MS events, classes or trainings. Honestly I have been only one day SCCM class in my career as an… Read More »

SCCM Search Tool (beta)

Has been in my mind to make a new tool, just didn’t know what do I make. Finally on Friday I made up my mind to make a SCCM search tool. Some time ago when we were doing troubleshooting, reading sccm log files, and have no idea what those long numbers means, example: 674ab-eec5-40e1-a5f2-9. 😀 You need Admin… Read More »

All components Type and Availability shows “Unknown”. Failed to read the required Operations Management component registry key values on local computer; error = 6 (0x6).

This morning, I noticed in our SCCM Primary server, all components Type and Availability shows “Unknown” After awhile, “Type” and “Availability” shows correctly, about 60 minutes later, it shows “Unknown” again, and it just repeatedly changes itself. We rebooted the server, but it didn’t help. Investigating further, I saw that the compmon.log on the site server displayed the… Read More »

SCCM 1606 BUG? 32-bit process Powershell detection method doesn’t work

As you know, you can use powershell detection method when you create Application in SCCM. Usually, I use this script, and it has been working for many years: $app = Get-WmiObject Win32Reg_AddRemovePrograms  | where-object {$_.DisplayName -like “Your Application name”} if ($app -ne $null) { write-host Installed } I choosed “Run script as 32-bit process on 64-bit clients”. Because clients are… Read More »